View Full Version : Touch woes - but I'm still optimistic.

06-10-11, 10:43 AM
Hi there,

I'm streaming Spotify through my Touch and have realy enjoyed the variety of music available. However I am often plagued by seemingly random re-buffering. I have always used wi-fi and have tried swapping channels in case it was an interference but this doesn't solve the problem. so the next step was to shift to a wired ethernet connection but the touch cannot find a dhcp address. when I assign a static ip address ithe touch says that it cannot find (this is throughpower plugs).

I hear tales of people having no trouble at all setting up their touch on their ethernet so know it's possible. I can't help feeling that it's something very simple.

Anyone got any ideas or pointers?

Many thanks,


Jo Sharp
06-10-11, 01:22 PM
Try looking through the Touch forum here:

06-10-11, 01:37 PM
Try a bit of CAT5 cabling directly into your router to rule out your power plugs.

06-10-11, 11:35 PM
I had a similar problem. You need to get the user/password for deleted from your unit.

Try this: Delete the player on (web), Factory Reset the Touch, it should offer to enter new account info (scroll down when it says "we show this player already registered").

One way or another any SB player *must* be deleted from a account in order to re-register that player to a new account.
Either the original account holder logs in and deletes it or Logitech tech support does it.

So if that doesn't work, contact Logitech SB support and give them the MAC address of the device (on back) and ask them to delete the device from You should then be able to reset the login as you want.